summaryrefslogtreecommitdiffstats
diff options
authorRoss Burton <ross.burton@arm.com>2025-04-02 18:02:34 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2025-04-03 11:05:48 +0100
commitc8c391ed3e0598a3bea7bc0981126d870315063d (patch)
tree012ad0e4910bbfb0dc8b2e652d9dae4cd8374b03
parent020b6b1411c9fd3adb208808c0d56623190873f8 (diff)
downloadopenembedded-core-c8c391ed3e0598a3bea7bc0981126d870315063d.tar.gz
python3: remove obsolete deletion of non-deterministic .pyc files
These .pyc files were non-deterministic because they used frozensets[1], but this has been fixed in 3.11 onwards. [1] https://github.com/python/cpython/issues/81777 [2] https://github.com/python/cpython/commit/51999c960e7fc45feebd629421dec6524a5fc803 Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3_3.13.2.bb14
1 files changed, 0 insertions, 14 deletions
diff --git a/meta/recipes-devtools/python/python3_3.13.2.bb b/meta/recipes-devtools/python/python3_3.13.2.bb
index 7c36fd92ed..0f0505c66c 100644
--- a/meta/recipes-devtools/python/python3_3.13.2.bb
+++ b/meta/recipes-devtools/python/python3_3.13.2.bb
@@ -235,20 +235,6 @@ do_install:append() {
$sysconfigfile
cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
-
- # Unfortunately the following pyc files are non-deterministc due to 'frozenset'
- # being written without strict ordering, even with PYTHONHASHSEED = 0
- # Upstream is discussing ways to solve the issue properly, until then let's
- # just not install the problematic files.
- # More info: http://benno.id.au/blog/2013/01/15/python-determinism
- rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_range.cpython*
- rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_xml_etree.cpython*
-
- # Similar to the above, we're getting reproducibility issues with
- # /usr/lib/python3.10/__pycache__/traceback.cpython-310.pyc
- # so remove it too
- rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/__pycache__/traceback.cpython*
-
# Remove the opt-1.pyc and opt-2.pyc files. They effectively waste space on embedded
# style targets as they're only used when python is called with the -O or -OO options
# which is rare.